1. ~~A tall sidebar breaks the footer. Noticable on ConsumeProduct.~~ Fixed
            
2. ~~Access logs were bugged and can't be effectively disabled by admins for existing accounts. [Please check whether you are affected and turn them off](https://arete.network/accesslogs/me/). For privacy reasons these should always be opt-in.~~ Fixed
            
3. Thumbnail generation for images sometimes causes an internal server error, but the post still goes through. (may have already been unintentionally fixed, haven't noticed any more errors in the logs)
           
4. ~~Unable to vote from the notifications dropdown. Vote arrows did show up in development.~~ Fixed
          
5. ~~Commenting on your own post generates a notification~~ Fixed
            
6. ~~The colored arrow indicator for a comment voted on cascades to all visible child comments.~~ Fixed
      
7. ~~Blank comment after edit (just a visual bug, it does actually save properly)~~ Fixed
     
8. ~~Marking modmail as read causes your personal inbox's unread count to go into the negatives until server restart~~ Fixed
  
9. ~~Incorrect post title length limit~~ Fixed
            
Please report any if you notice them.

You must log in to comment
38 comments:
9 months ago 6 points (+6 / -0 )
This is amazing. Congrats and thanks for being a difference-maker.
 
It would be nice on mobile to have the banner at the top serve as a link to bring users back to that community's hot page.
None
9 months ago 4 points (+4 / -0 )
This is HUGE man.
  
ConPro is safe for the foreseeable future! Well done!
 
 
Now let me touch up our CSS please.
None
9 months ago 3 points (+3 / -0 ) Edited 2022-04-08 00:39:55 1 child
I got a minor bug, on smaller phones, images in portrait mode get cut off
  
As a feature request, I got kind of used to the Hot, New, Rising sort options on the .win network, not sure how hard that would be to implement but I'd put a vote in for that.
 
Edit: looks fixed! Thanks!
None
9 months ago 0 points (+0 / -0 )
I now see that Hot exists so I guess my feature request is just for the Rising option 🙃
None
9 months ago 2 points (+2 / -0 ) 1 child
Commenting on your own post should just be a 1/0 issue. I'm sure there's a line of code somewhere about generating a notification due to a comment. I have not done coding in a long time, but that's what it would seem like to me. Seems like a minor issue to hammer out over time.
None
9 months ago 1 point (+1 / -0 )
He just needs to compare both users. Only create notifications if they are different users. Usually the difficulties lie in other things though. Maybe he does not yet receive the name or ID of the user of the comment to which is responded to and merely used its comment ID. Things like that...
None
8 months ago 2 points (+2 / -0 )
Same issue as MrBojangles: The resolution seems to be variable and some posts get cut off. It's only wide images and probably only affecting lower resolution devices.
 
Another bug I noticed is when on the same old phone, tapping the search bar brings up the sort options.
 
Other than that, this is excellent! I will report any other bugs I find.
None
9 months ago 1 point (+1 / -0 ) 1 child
If I enter a 1 character username, the error message is:
 
"Your username must be at least"
 
That's it, no length or any other reqs listed. Please let me have a 1 char username. They are cool.
None
9 months ago 0 points (+0 / -0 )
Removing the limit when I push the next update. The current limit is 3 chars.
None
deleted 9 months ago 1 point (+1 / -0 ) 1 child
Account deactivated by its owner
9 months ago 1 point (+1 / -0 )
I've discovered the cause of this. The character limit for a title when saving a post is supposed to be 256 (which I believe is more than enough), but they are truncated to half of that limit on submission.
 
The fix will be applied in the next update.
None
9 months ago 1 point (+1 / -0 ) 3 children
I randomly get API Call Error when attempting to upvote content, but it comes and goes. Not sure if bug, but reporting it anyway.
None
9 months ago 1 point (+1 / -0 )
Rapidly clicking the same vote button messes up the count client-side, but this is just a visual bug and no errors occur.
None
9 months ago 1 point (+1 / -0 )
Interesting. @SwampRangers also had that issue. I'll check the logs to see if any errors popped up.
None
9 months ago 1 point (+1 / -0 ) 1 child
I don't see any errors. Do you remember which post you failed to vote on?
 
I haven't been able to reproduce this personally.
None
9 months ago 1 point (+1 / -0 )
I'm sorry, I don't recall. If it helps, I am on mobile at the moment and if it happens again I will get the exact post. This happens from the front of the board, not inside a post or comment section. At least not yet.
None
3 months ago 0 points (+0 / -0 ) 1 child
Hey, it looks better right now without scripts than it did several hours ago, nice, your hard work shows.
 
It still doesn't load the image without scripts if the post is an image though, the .win site did that.
None
3 months ago 0 points (+0 / -0 ) 1 child
Huh? I didn't change anything within the last day. Yes, scripts are required for image posts to display. It invokes the same function call to expand the preview as if you did it manually from the post listing. You should still be able to open the image url by clicking on the post title however.
 
Many things are rendered by clientside scripts, including buttons under content. It may work without, but definitely expect lots of issues.
None
3 months ago 0 points (+0 / -0 )
Right, now that I see it, only posts that are images load properly without scripts, text posts still look weird and overlap each other. It just so happens that a lot of recent posts have been images, and it looked better to me.
 
Most of the time I lurk without scripts, I only run scripts when I'm logged in.
None
3 months ago 0 points (+0 / -0 ) 1 child
How secure is the "access log" feature?
None
3 months ago 1 point (+1 / -0 ) Edited 2022-08-10 17:46:59 1 child
It's mostly there for the admin accounts / mods. You can safely ignore it. Logs any and all login attempts, including those with an invalid password, etc.
    
However, this does mean that your IP address will be stored on the server in plaintext until you clear it. I don't otherwise store that data.
3 months ago 0 points (+0 / -0 )
Great. Thanks for the quick reply.
None
3 months ago 0 points (+0 / -0 ) 1 child
It seems like when I expand text posts, like the quick view from the feed, that those won't open like images do. On mobile.
None
3 months ago 1 point (+1 / -0 ) 2 children
What browser do you use? There should be no issues with this.
None
3 months ago 0 points (+0 / -0 )
Safari on iOS
None
3 months ago 0 points (+0 / -0 ) 1 child
For context, this one expands without issue:
 
https://arete.network/b/ConsumeProduct/p/3219/
 
This one doesn't expand:
 
https://arete.network/b/ConsumeProduct/p/3217/capitalism
 
So maybe it's a text length thing?
None
3 months ago 1 point (+1 / -0 ) 1 child
Shorter posts are preloaded, longer ones get fetched as you click expand. I've made some adjustments to how they're expanded for the next update, maybe it'll work, maybe not. I don't have any way to test it for iOS.
None
3 months ago 0 points (+0 / -0 ) 1 child
No worries, cool that you found it.
None
3 months ago 0 points (+0 / -0 ) 1 child
This update is now live. Is the issue fixed?
None
-1
9 months ago -1 points (+1 / -2 ) 1 child
Fast work, admin.
 
Issue: I downvoted and then tried to cancel by clicking a second time and got an error. Maybe votes are meant to be permanent forever?
None
9 months ago 1 point (+1 / -0 )
They aren't. Maybe you clicked too fast, idk. Try again.
None
-3
9 months ago -3 points (+1 / -4 ) 2 children
Mobile site is ugly as sin.
None
9 months ago 6 points (+6 / -0 )
Downvoting appears to work right.
None
9 months ago 0 points (+0 / -0 ) 2 children
Yeah.
 
Each post has its own collapsible column that houses a single button “-“ that eats up horizontal space quickly. That button should be part of the post container, maybe above the up/down vote button to eliminate the column entirely.
 
The text size is smaller in the editor than the posts.
 
The “sticker” button at next to save/cancel buttons in the post editor overlaps into the editor container. It’s easy to accidentally hit it.
 
The save/cancel buttons are partially obscured at the top, probably due to how the sticker button is rendered on the same container.
 
One thing I loved about old voat was the “source” button under each post so I could copypasta text with the markdown code. Neither nuvoat nor .win have it, and I have to do extra copypasta for links or emphasis / header related markdown.
None
9 months ago 0 points (+0 / -0 )
> One thing I loved about old voat was the “source” button under each post so I could copypasta text with the markdown code
  
Planned as one of the options under a general "share" button.
None
9 months ago 0 points (+0 / -0 )
Also thanks for the other feedback
None
Toast message